piccolo HOWTO – Mandriva 2010.2 e AT&T Global Network Client

piccolo HOWTO – Mandriva 2010.2 e AT&T Global Network Client

Installazione AT&T Global network client su Mandriva 2010.2 con kernel 2.6.36.2-desktop-2mnb.

Ultima versione attualmente disponibile (ed installata) del client VPN:
agnclient-1.0-2.0.1.3003.i386.rpm (461 KB).
Tentando l’installazione del pacchetto, a causa delle dipendenze, questa fallirà, per risolvere ho dovuto installare anche i seguenti pacchetti (grazie a rpm.pbone.net):

libcurl3-7.15.5-2mdv2007.0 (171 KB);
openssl097a-0.9.7a-9 (824 KB);
openssl-1.0.0a-1.7mdv2010.2 (370 KB);

Per risolvere un errore lanciando il client da terminale (ma che non inficia il corretto funzionamento della VPN), potete installare anche i pacchetti:
libvorbisfile3-1.3.1-1mdv2010.1
libcanberra0-0.24-2mdv2010.1
libcanberra-gtk0-0.24-2mdv2010.1

che trovate nel repository.

Ecco le dipendenze delle librerie condivise per agnclient:

$ ldd /opt/agns/bin/agnclient
linux-gate.so.1 => (0xffffe000)
libagnLogc.so.1 => /opt/agns/lib/libagnLogc.so.1 (0xf76db000)
libagnc.so.1 => /opt/agns/lib/libagnc.so.1 (0xf76d2000)
libpthread.so.0 => /lib/libpthread.so.0 (0xf76ba000)
libm.so.6 => /lib/libm.so.6 (0xf7694000)
libdl.so.2 => /lib/libdl.so.2 (0xf768f000)
libgtk-x11-2.0.so.0 => /usr/lib/libgtk-x11-2.0.so.0 (0xf726b000)
libgdk-x11-2.0.so.0 => /usr/lib/libgdk-x11-2.0.so.0 (0xf71c8000)
libatk-1.0.so.0 => /usr/lib/libatk-1.0.so.0 (0xf71a9000)
libgdk_pixbuf-2.0.so.0 => /usr/lib/libgdk_pixbuf-2.0.so.0 (0xf718e000)
libpangoxft-1.0.so.0 => /usr/lib/libpangoxft-1.0.so.0 (0xf7184000)
libpangox-1.0.so.0 => /usr/lib/libpangox-1.0.so.0 (0xf7177000)
libpango-1.0.so.0 => /usr/lib/libpango-1.0.so.0 (0xf712e000)
libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0xf70ea000)
libgmodule-2.0.so.0 => /usr/lib/libgmodule-2.0.so.0 (0xf70e5000)
libgthread-2.0.so.0 => /usr/lib/libgthread-2.0.so.0 (0xf70de000)
libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0xf7004000)
libxml2.so.2 => /usr/lib/libxml2.so.2 (0xf6ec3000)
libc.so.6 => /lib/libc.so.6 (0xf6d71000)
/lib/ld-linux.so.2 (0xf76fe000)
libpangocairo-1.0.so.0 => /usr/lib/libpangocairo-1.0.so.0 (0xf6d65000)
libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0xf6d5e000)
libcairo.so.2 => /usr/lib/libcairo.so.2 (0xf6ca6000)
libX11.so.6 => /usr/lib/libX11.so.6 (0xf6b74000)
libgio-2.0.so.0 => /usr/lib/libgio-2.0.so.0 (0xf6ac2000)
libpangoft2-1.0.so.0 => /usr/lib/libpangoft2-1.0.so.0 (0xf6a98000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xf6a63000)
libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xf6a5f000)
libXi.so.6 => /usr/lib/libXi.so.6 (0xf6a50000)
libXrandr.so.2 => /usr/lib/libXrandr.so.2 (0xf6a47000)
libXcursor.so.1 => /usr/lib/libXcursor.so.1 (0xf6a3c000)
libXcomposite.so.1 => /usr/lib/libXcomposite.so.1 (0xf6a38000)
libXext.so.6 => /usr/lib/libXext.so.6 (0xf6a25000)
libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0xf6a21000)
libXrender.so.1 => /usr/lib/libXrender.so.1 (0xf6a17000)
libXft.so.2 => /usr/lib/libXft.so.2 (0xf6a01000)
librt.so.1 => /lib/librt.so.1 (0xf69f8000)
libpcre.so.0 => /lib/libpcre.so.0 (0xf69c4000)
libz.so.1 => /lib/libz.so.1 (0xf69b1000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xf692d000)
libpixman-1.so.0 => /usr/lib/libpixman-1.so.0 (0xf68b1000)
libpng12.so.0 => /usr/lib/libpng12.so.0 (0xf686a000)
libxcb.so.1 => /usr/lib/libxcb.so.1 (0xf684a000)
libresolv.so.2 => /lib/libresolv.so.2 (0xf6835000)
libXau.so.6 => /usr/lib/libXau.so.6 (0xf6831000)
libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xf682a000)

Buon lavoro.

Annunci

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...